]> Pileus Git - ~andy/sunrise/blob - net-irc/xchat-randex/xchat-randex-1.20.ebuild
app-dicts/words-bin: Adding ~amd64 keyword
[~andy/sunrise] / net-irc / xchat-randex / xchat-randex-1.20.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit multilib
8
9 DESCRIPTION="XChat plugin for entropy exchange over IRC"
10 HOMEPAGE="http://www.mirbsd.org/"
11
12 # Version of arc4random.c to use for build
13 MY_ARC4RANDOM_V="1.28"
14
15 SRC_URI="http://www.mirbsd.org/MirOS/dist/hosted/xchat-randex/${P}.tar.gz
16         http://www.mirbsd.org/MirOS/dist/hosted/other/arc4random.c.${MY_ARC4RANDOM_V}
17         "
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE=""
23
24 RDEPEND="net-irc/xchat"
25
26 S="${WORKDIR}/${PN}"
27
28 src_unpack() {
29         default
30
31         cp "${DISTDIR}/arc4random.c.${MY_ARC4RANDOM_V}" "${S}/arc4random.c" || die
32 }
33
34 src_compile() {
35         emake -f Make_lnx
36 }
37
38 src_install() {
39         insinto "/usr/$(get_libdir)/xchat/plugins"
40
41         doins randex.so
42         dodoc README
43 }