]> Pileus Git - ~andy/sunrise/blob - net-irc/irssi-otr/irssi-otr-0.1.ebuild
net-irc/irssi-otr: net-irc/irssi-otr: New Ebuild and package for bug 228031. Thanks...
[~andy/sunrise] / net-irc / irssi-otr / irssi-otr-0.1.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit cmake-utils eutils
6
7 DESCRIPTION="Off-The-Record messaging (OTR) for irssi"
8 HOMEPAGE="http://projects.tuxfamily.org/group.pl?name=irssiotr"
9
10 # This should probably be exported by cmake-utils as a variable
11 CMAKE_BINARY_DIR="${WORKDIR}"/${PN}_build
12
13 MY_PV=v${PV/_/-}
14 S="${WORKDIR}/irssiotr"
15
16 MY_IRSSI_URL="http://svn.irssi.org/cgi-bin/viewvc.cgi/irssi/trunk/src/fe-text"
17 MY_IRSSI_URLPARMS="revision=4806&root=irssi"
18 SRC_URI="
19         ${MY_IRSSI_URL}/mainwindows.h?${MY_IRSSI_URLPARMS}
20         ${MY_IRSSI_URL}/term.h?${MY_IRSSI_URLPARMS}
21         ${MY_IRSSI_URL}/statusbar.h?${MY_IRSSI_URLPARMS}
22         http://git.tuxfamily.org/irssiotr/irssiotr.git?p=gitroot/irssiotr/irssiotr.git;a=snapshot;h=${MY_PV};sf=tgz"
23
24 LICENSE="GPL-2"
25 SLOT="0"
26 KEYWORDS="~amd64 ~x86"
27 IUSE="debug"
28
29 RDEPEND="
30         >=net-libs/libotr-3.1.0
31         net-irc/irssi"
32
33 DEPEND="${RDEPEND}
34         dev-libs/glib
35         >=dev-util/cmake-2.4.7
36         dev-util/pkgconfig
37         dev-lang/python"
38
39 src_unpack() {
40         ln -s "${DISTDIR}/irssiotr.git;a=snapshot;h=${MY_PV};sf=tgz" ${P}.tgz
41         unpack ./${P}.tgz
42
43         mkdir -p "${CMAKE_BINARY_DIR}"
44
45         # copy prefetched irssi private headers and patch them
46         # a bug has been filed to make these public, irssi FS#535
47         for privheader in mainwindows.h term.h statusbar.h; do
48                 cp "${DISTDIR}/${privheader}?${MY_IRSSI_URLPARMS}" \
49                         "${CMAKE_BINARY_DIR}/${privheader}" \
50                         || die "failed to copy prefetched irssi private headers"
51         done
52         cd "${CMAKE_BINARY_DIR}"
53         epatch "${S}"/privheaders.patch
54         mycmakeargs="-DIRSSIOTR_VERSION=${PV}"
55 }