]> Pileus Git - ~andy/sunrise/blob - net-im/spark/spark-2.5.8.ebuild
x11-plugins/pidgin-sendscreenshot: Properly fix qt deps
[~andy/sunrise] / net-im / spark / spark-2.5.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils java-pkg-2
6
7 DESCRIPTION="Spark is an Open Source, cross-platform IM client optimized for businesses and organizations"
8 HOMEPAGE="http://www.igniterealtime.org/projects/spark/"
9 SRC_URI="http://www.igniterealtime.org/builds/spark/${PN//-/_}_${PV//./_}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="doc"
15
16 RDEPEND=">=virtual/jre-1.5"
17 DEPEND=">=virtual/jdk-1.5
18         app-arch/unzip"
19
20 S=${WORKDIR}/Spark
21
22 src_install() {
23         java-pkg_dojar lib/*.jar
24         java-pkg_dojar .install4j/*.jar
25
26         insinto /usr/share/spark
27         doins -r resources xtra plugins || die
28
29         dobin "${FILESDIR}"/spark.sh || die
30         unzip -qq lib/spark.jar
31         doicon "${WORKDIR}"/images/spark-64x64.png
32         make_desktop_entry spark.sh "Spark IM" spark-64x64 "Network;InstantMessaging"
33
34         if use doc; then
35                 dohtml -r documentation/* || die
36         fi
37 }
38
39 pkg_postinst() {
40         ewarn "If you have problems with system-tray, read following:"
41         ewarn "http://www.igniterealtime.org/community/message/168762#168711"
42         ewarn
43         ewarn "And then, please, do:"
44         ewarn "1. replace /usr/share/spark/plugins/jniwrapper.jar with attachment from the post above;"
45         ewarn "2. remove ~/.Spark/plugins"
46         ewarn "3. re-start Spark IM"
47 }