]> Pileus Git - ~andy/sunrise/blob - net-im/qutecom/qutecom-2.2_p20090606.ebuild
sunrise/ app-misc/autokey-gtk: New Ebuild for autokey
[~andy/sunrise] / net-im / qutecom / qutecom-2.2_p20090606.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit cmake-utils eutils
8
9 DESCRIPTION="Multi-protocol instant messenger and VoIP client"
10 HOMEPAGE="http://www.qutecom.com/"
11 SRC_URI="http://omploader.org/vMXNucg/${P}.tar.lzma"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="alsa debug oss portaudio xv"
17
18 DEPEND=">=dev-libs/boost-1.34
19         dev-libs/glib
20         dev-libs/openssl
21         alsa? ( media-libs/alsa-lib )
22         media-libs/libsamplerate
23         media-libs/libsndfile
24         portaudio? ( media-libs/portaudio )
25         media-libs/speex
26         media-video/ffmpeg
27         net-im/pidgin[gnutls]
28         net-libs/gnutls
29         >=net-libs/libosip-3
30         >=net-libs/libeXosip-3
31         net-misc/curl
32         x11-libs/libX11
33         x11-libs/qt-gui
34         x11-libs/qt-svg
35         xv? ( x11-libs/libXv )"
36 RDEPEND=${DEPEND}
37
38 src_configure() {
39         local mycmakeargs="$(cmake-utils_use_enable portaudio PORTAUDIO_SUPPORT) \
40                 $(cmake-utils_use_enable alsa PHAPI_AUDIO_ALSA_SUPPORT) \
41                 $(cmake-utils_use_enable oss PHAPI_AUDIO_OSS_SUPPORT) \
42                 $(cmake-utils_use_enable xv WENGOPHONE_XV_SUPPORT) \
43                 -DLIBPURPLE_INTERNAL=OFF \
44                 -DPORTAUDIO_INTERNAL=OFF "
45
46         cmake-utils_src_configure
47 }
48
49 src_install() {
50         cmake-utils_src_install
51         domenu wengophone/res/${PN}.desktop || die "domenu failed"
52         doicon wengophone/res/${PN}_64x64.png || die "doicon failed"
53
54 }