]> Pileus Git - ~andy/sunrise/blob - net-im/pyxmpp/pyxmpp-1.0.0-r2.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / net-im / pyxmpp / pyxmpp-1.0.0-r2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit eutils distutils
8
9 DESCRIPTION="A Python XMPP (RFC 3920,3921) and Jabber implementation"
10 HOMEPAGE="http://pyxmpp.jajcus.net/"
11 SRC_URI="http://pyxmpp.jajcus.net/downloads/${P}.tar.gz"
12
13 LICENSE="LGPL-2.1"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 DEPEND=">=dev-lang/python-2.3
19         >=dev-libs/libxml2-2.6.23[python]"
20 RDEPEND="${DEPEND}
21         >=dev-python/dnspython-1.3.2
22         >=dev-python/m2crypto-0.13.1"
23
24 src_install() {
25         DOCS="CHANGES"
26         distutils_src_install
27         if use doc; then
28                 dohtml -r doc/www/* || die "Dohtml failed"
29         fi
30 }