]> Pileus Git - ~andy/sunrise/blob - net-im/freetalk/freetalk-3.2.ebuild
sci-geosciences/aweather: Version bump for aweather-0.8.1
[~andy/sunrise] / net-im / freetalk / freetalk-3.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit autotools eutils
8
9 DESCRIPTION="Console based Jabber client"
10 HOMEPAGE="http://www.gnu.org/software/freetalk/"
11 SRC_URI="http://savannah.gnu.org/download/${PN}/${P}.tar.gz"
12
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 LICENSE="GPL-3"
16 IUSE=""
17
18 RDEPEND="
19         dev-libs/glib:2
20         dev-scheme/guile
21         net-libs/loudmouth"
22 DEPEND="${RDEPEND}"
23
24 src_prepare() {
25         epatch \
26                 "${FILESDIR}"/${PV}-callback.patch \
27                 "${FILESDIR}"/${PV}-asneeded.patch \
28                 "${FILESDIR}"/${PV}-aclocal.patch
29         eautoreconf
30 }
31
32 src_install() {
33         emake DESTDIR="${D}" install || die
34 }