]> Pileus Git - ~andy/sunrise/blob - net-im/cjc/cjc-1.0.0.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / net-im / cjc / cjc-1.0.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="The Console Jabber Client - Jabber client with text-based user interface"
8 HOMEPAGE="http://cjc.jajcus.net/trac/"
9 SRC_URI="http://cjc.jajcus.net/downloads/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13
14 KEYWORDS="~x86"
15
16 IUSE=""
17 DEPEND=""
18 RDEPEND=">=dev-lang/python-2.4.2
19         >=net-im/pyxmpp-1.0.0"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}/${P}-plugins-dir.patch"
25         epatch "${FILESDIR}/${P}-path-fix.patch"
26         epatch "${FILESDIR}/${P}-Makefile-fix.patch"
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die "emake install failed"
31         dohtml doc/manual.html
32 }