]> Pileus Git - ~andy/sunrise/blob - net-fs/httpfs/httpfs-2.06.08.26.ebuild
Cosmetics
[~andy/sunrise] / net-fs / httpfs / httpfs-2.06.08.26.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Fuse-based httpfs file system"
6 HOMEPAGE="http://httpfs.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
8
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~x86"
12
13 IUSE=""
14
15 DEPEND="sys-fs/fuse"
16 RDEPEND=${DEPEND}
17
18 S=${WORKDIR}
19
20 src_unpack() {
21         unpack ${A}
22         # The script doesn't accept custom CFLAGS. Fix it.
23         sed -i \
24                 -e 's:^gcc -c -O2 -g -Wall \(.*\)$:gcc -c ${CFLAGS} \1:' \
25                 -e 's:^gcc -s \(.*\):gcc ${CFLAGS} \1:' \
26                 make_httpfs || die "sed make_httpfs failed"
27 }
28
29 src_compile() {
30         ./make_httpfs || die "make_httpfs failed"
31 }
32
33 src_install() {
34         dobin httpfs
35         newdoc readme.2 readme
36 }