]> Pileus Git - ~andy/sunrise/blob - net-fs/httpfs/httpfs-2.06.08.26.ebuild
net-fs/httpfs: New ebuild for bug 177376 thanks to 'ps'
[~andy/sunrise] / net-fs / httpfs / httpfs-2.06.08.26.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Fuse-based httpfs file system"
6 HOMEPAGE="http://httpfs.sourceforge.net/"
7 SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
8
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~x86"
12
13 IUSE=""
14
15 RDEPEND="sys-fs/fuse"
16
17 S=${WORKDIR}
18
19 src_unpack() {
20         unpack ${A}
21         # The script doesn't accept custom CFLAGS. Fix it.
22         sed -i \
23                 -e 's:^gcc -c -O2 -g -Wall \(.*\)$:gcc -c ${CFLAGS} \1:' \
24                 -e 's:^gcc -s \(.*\):gcc ${CFLAGS} \1:' \
25                 make_httpfs || die "sed make_httpfs failed"
26 }
27
28 src_compile() {
29         ./make_httpfs || die "make_httpfs failed"
30 }
31
32 src_install() {
33         dobin httpfs
34         dodoc readme.2
35 }