]> Pileus Git - ~andy/sunrise/blob - net-fs/httpfs/httpfs-2.06.08.26.ebuild
Install more docs ;)
[~andy/sunrise] / net-fs / httpfs / httpfs-2.06.08.26.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit toolchain-funcs
6
7 DESCRIPTION="Fuse-based httpfs file system"
8 HOMEPAGE="http://httpfs.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/httpfs_with_static_binaries_${PV}.tar.gz"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~x86"
14
15 IUSE=""
16
17 DEPEND="sys-fs/fuse"
18 RDEPEND=${DEPEND}
19
20 S=${WORKDIR}
21
22 src_unpack() {
23         unpack ${A}
24         # The script doesn't accept custom CFLAGS. Fix it.
25         sed -i \
26                 -e "s:^gcc -c -O2 -g -Wall \(.*\)$:$(tc-getCC) -c ${CFLAGS} \1:" \
27                 -e "s:^gcc -s \(.*\):$(tc-getCC) ${CFLAGS} \1:" \
28                 make_httpfs || die "sed make_httpfs failed"
29 }
30
31 src_compile() {
32         ./make_httpfs || die "make_httpfs failed"
33 }
34
35 src_install() {
36         dobin httpfs
37         newdoc readme.2 README
38         newdoc readme RELEASE-NOTES
39 }