]> Pileus Git - ~andy/sunrise/blob - net-firewall/nufw/nufw-2.1.0.ebuild
net-firewall/nufw: Version bump
[~andy/sunrise] / net-firewall / nufw / nufw-2.1.0.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="An enterprise grade authenticating firewall based on netfilter"
6 HOMEPAGE="http://www.nufw.org/"
7 SRC_URI="http://www.nufw.org/download/${PN}/${P}.tar.bz2"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE="debug gdbm ident ldap mysql pam pam_nuauth pic postgres prelude \
13 unicode nfqueue nfconntrack"
14
15 DEPEND=">=dev-libs/glib-2
16         dev-libs/libgcrypt
17         >=dev-libs/cyrus-sasl-2
18         net-firewall/iptables
19         >=net-libs/gnutls-1.1
20         gdbm? ( sys-libs/gdbm )
21         ident? ( net-libs/libident )
22         ldap? ( >=net-nds/openldap-2 )
23         mysql? ( dev-db/mysql )
24         pam_auth? ( sys-libs/pam )
25         postgres? ( dev-db/postgresql )
26         nfqueue? ( net-firewall/libnfnetlink
27                 net-firewall/libnetfilter_queue )
28         nfconntrack? ( net-firewall/libnetfilter_conntrack )"
29 RDEPEND="${DEPEND}"
30
31 src_compile() {
32         econf \
33                 $(use_enable pam_nuauth pam-nuauth) \
34                 $(use_with pic) \
35                 $(use_with prelude prelude-log) \
36                 $(use_with mysql mysql-log) \
37                 $(use_with postgres pgsql-log) \
38                 $(use_with pam system-auth) \
39                 $(use_with ldap) \
40                 $(use_with gdbm) \
41                 $(use_with ident) \
42                 $(use_with nfqueue) \
43                 $(use_with nfconntrack) \
44                 $(use_with unicode utf8) \
45                 $(use_enable debug) \
46                 --sysconfdir="/etc/nufw" \
47                 --localstatedir="/var" \
48                 || die "econf failed"
49         emake || die "emake failed"
50 }
51
52 src_install() {
53         emake DESTDIR="${D}" install || die "emake install failed"
54
55         newinitd "${FILESDIR}"/nufw-init.d nufw
56         newconfd "${FILESDIR}"/nufw-conf.d nufw
57
58         newinitd "${FILESDIR}"/nuauth-init.d nuauth
59         newconfd "${FILESDIR}"/nuauth-conf.d nuauth
60
61         insinto /etc/nufw
62         doins conf/nuauth.conf
63         keepdir /var/run/nuauth
64
65         dodoc AUTHORS ChangeLog NEWS README TODO
66         docinto scripts
67         dodoc scripts/*
68         docinto conf
69         dodoc conf/*
70 }