]> Pileus Git - ~andy/sunrise/blob - net-dns/nsd/nsd-3.0.4.ebuild
Remove unneeded local USE flag
[~andy/sunrise] / net-dns / nsd / nsd-3.0.4.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="an authoritative only, high performance, open source name server"
8 HOMEPAGE="http://www.nlnetlabs.nl/nsd/"
9 SRC_URI="http://www.nlnetlabs.nl/downloads/nsd/${P}.tar.gz"
10
11 LICENSE="as-is"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="axfr bind8-stats checking dnssec ipv6 nsec3 nsid plugins root-server ssl tcpd tsig"
15
16 DEPEND="ssl? ( >=dev-libs/openssl-0.9.7i )
17         tcpd? ( sys-apps/tcp-wrappers )"
18
19 pkg_setup() {
20         enewuser nsd -1 -1 /var/lib/nsd
21 }
22
23 src_compile() {
24         if use plugins; then
25                 ewarn
26                 ewarn "Plugin support is highly experimental!"
27                 ewarn "Plugin support enabled!"
28                 epause 10
29         fi
30
31         econf \
32                 --with-user=nsd \
33                 --with-dbfile=/var/lib/nsd/nsd.db \
34                 --with-pidfile=/var/run/nsd/nsd.pid \
35                 --with-zonesdir=/var/lib/nsd \
36                 --with-difffile=/var/run/nsd/ \
37                 --with-xfrdfile==/var/run/nsd/ \
38                 $(use_enable axfr) \
39                 $(use_enable bind8-stats) \
40                 $(use_enable checking) \
41                 $(use_enable dnssec) \
42                 $(use_enable ipv6) \
43                 $(use_enable nsec3) \
44                 $(use_enable nsid) \
45                 $(use_enable plugins) \
46                 $(use_enable root-server) \
47                 $(use_with ssl) \
48                 $(use_enable tsig) || die "econf failed"
49
50         emake || die "emake failed"
51 }
52
53 src_install() {
54         emake DESTDIR="${D}" install || die "emake install failed"
55
56         dodoc doc/*
57         dodoc contrib/nsd.zones2nsd.conf
58
59         dobin nsdc.sh
60
61         exeinto /etc/cron.hourly
62         newexe "${FILESDIR}"/nsd.cron nsd.cron
63
64         newinitd "${FILESDIR}"/nsd.initd nsd
65
66         keepdir /var/run/nsd
67         fowners nsd /var/run/nsd
68         fperms 750 /var/run/nsd
69
70         keepdir /var/lib/nsd
71         fowners nsd /var/lib/nsd
72         fperms 750 /var/lib/nsd
73 }