]> Pileus Git - ~andy/sunrise/blob - net-dns/inadyn-mt/inadyn-mt-02.14.10.ebuild
42dd72d48461b1049df101c5a74e79daa805b787
[~andy/sunrise] / net-dns / inadyn-mt / inadyn-mt-02.14.10.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils
8
9 MY_P=${PN}.v.${PV}
10
11 DESCRIPTION="Dynamic DNS (DynDNS) Update daemon in C that supports multiple services"
12 HOMEPAGE="http://sourceforge.net/projects/inadyn-mt"
13 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE="+threads +async"
19
20 RDEPEND="!net-dns/inadyn"
21
22 S=${WORKDIR}/${PN}/${MY_P}
23
24 pkg_setup() {
25         enewuser ${PN}
26
27         GETHOSTBYNAME_PARAMS=3
28
29         if use threads ; then
30                 USE_THREADS=1
31                 if use async ; then
32                         ASYNC_LOOKUP=1
33                 fi
34         fi
35         TARGET_ARCH=linux
36 }
37
38 src_install() {
39         cd "${MY_P}"
40
41         dosbin bin/linux/${PN} || die
42
43         # inadyn-mt comes with outdated inadyn man pages - see inadyn-mt bug 2445206
44         rm man/inadyn.8 man/inadyn.conf.5 || die
45         # end workaround
46
47         doman man/* || die
48
49         dohtml readme.html || die
50
51         newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
52
53         insinto /etc
54         doins "${FILESDIR}"/${PN}.conf || die
55
56 }
57
58 pkg_postinst() {
59         elog "You will need to edit /etc/inadyn-mt.conf before running inadyn-mt"
60         elog "for the first time. The format is basically the same as the"
61         elog "command line options; see inadyn-mt and inadyn-mt.conf manpages."
62 }