]> Pileus Git - ~andy/sunrise/blob - net-analyzer/pulledpork/pulledpork-0.5.0.ebuild
net-analyzer/icinga: added libexecdir conditional on plugins use flag
[~andy/sunrise] / net-analyzer / pulledpork / pulledpork-0.5.0.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Perl script for Snort rule management"
6 HOMEPAGE="http://code.google.com/p/pulledpork/"
7 SRC_URI="http://pulledpork.googlecode.com/files/${P}.tar.gz"
8
9 SLOT="0"
10 LICENSE="GPL-2"
11 KEYWORDS="~amd64 ~x86"
12 IUSE=""
13
14 RDEPEND="dev-lang/perl
15         dev-perl/libwww-perl
16         dev-perl/Crypt-SSLeay
17         perl-core/Sys-Syslog
18         perl-core/Digest-MD5
19         perl-core/Archive-Tar
20         net-analyzer/snort"
21
22 src_install () {
23         dobin pulledpork.pl || die "Failed to install script pulledpork.pl"
24
25         dodoc README \
26                 doc/README.* \
27                 etc/*.conf || die "Failed to install docs in doc or etc"
28
29         docinto contrib
30         dodoc contrib/* || die "Failed to install docs in contrib"
31 }
32
33 pkg_postinst() {
34         elog "Example configuration files can be found in /usr/share/doc/${PF}."
35 }