]> Pileus Git - ~andy/sunrise/blob - net-analyzer/pf_ring-kmod/pf_ring-kmod-4.6.3.ebuild
app-admin/jailkit: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / net-analyzer / pf_ring-kmod / pf_ring-kmod-4.6.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit linux-mod linux-info
8
9 DESCRIPTION="A new type of network socket that improves packet capture speed."
10 HOMEPAGE="http://www.ntop.org/PF_RING.html"
11 SRC_URI="http://sourceforge.net/projects/ntop/files/PF_RING/PF_RING-${PV}.tar.gz/download -> ${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 S="${WORKDIR}/PF_RING-${PV}/kernel"
19
20 MODULE_NAMES="pf_ring(net/pf_ring:${S}:${S})"
21 CONFIG_CHECK="NET"
22 ERROR_NET="PF_RING-${PV} requires CONFIG_NET=y set in the kernel."
23 BUILD_TARGETS="modules"
24
25 pkg_setup() {
26         linux-mod_pkg_setup
27         BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S} EXTRA_CFLAGS='-I${S}'"
28 }
29
30 src_install() {
31         linux-mod_src_install
32         insinto /usr/include/linux
33         doins linux/pf_ring.h || die
34         insinto /etc/modprobe.d
35         doins "${FILESDIR}"/pf_ring.conf || die
36         sed -i -e 's:DOCDIR:/usr/share/doc/'${PF}'/README.module_options:g' \
37                 "${D}etc/modprobe.d/pf_ring.conf" || die
38         dodoc "${FILESDIR}"/README.module_options || die
39 }
40
41 pkg_postinst() {
42         einfo "Please see /usr/share/doc/${PF}/README.module_options for configuration options."
43         linux-mod_pkg_postinst
44 }