]> Pileus Git - ~andy/sunrise/blob - net-analyzer/nagios-check_multi/nagios-check_multi-0.24.ebuild
media-gfx/ktikz: Properly fix qt deps
[~andy/sunrise] / net-analyzer / nagios-check_multi / nagios-check_multi-0.24.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils multilib
6
7 DESCRIPTION="A multi-purpose wrapper plugin for Nagios"
8 HOMEPAGE="http://my-plugin.de/wiki/projects/check_multi/start"
9 SRC_URI="http://my-plugin.de/check_multi/check_multi-stable-${PV}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="dev-lang/perl"
17 RDEPEND="${DEPEND}
18         net-analyzer/nagios-plugins"
19
20 S=${WORKDIR}/check_multi-${PV}
21
22 src_compile() {
23         econf \
24                 --libexecdir=/usr/$(get_libdir)/nagios/plugins \
25                 --sysconfdir=/etc/nagios \
26                 --with-nagios-group=nagios
27
28         emake all || die "emake failed"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install install-config || die "emake install failed"
33
34         # set file permissions similar to nagios / nagios-plugins
35         fperms 0750 /usr/$(get_libdir)/nagios/plugins/check_multi \
36                 || die "Failed chmod of ${D}usr/$(get_libdir)/nagios/plugins/check_multi"
37
38         # the files in this directory have been incorrectly set executable permissions
39         # by the author. Author said that will be corrected in next version.
40         find "${D}"/etc/nagios/check_multi -type f -exec chmod 0640 {} \;
41
42         dodoc README Changelog  || die "dodoc failed"
43 }
44
45 pkg_postinst() {
46         elog "Check ${ROOT}/etc/nagios/check_multi for config examples."
47         elog "In case ${PN} is to be used with net-analyzer/nagios-nrpe"
48         elog "make sure that it is version 2.12-r103 or greater on both"
49         elog "the client and the server sides (see bug #264467)."
50 }