]> Pileus Git - ~andy/sunrise/blob - net-analyzer/icinga/icinga-1.0.2.ebuild
net-analyzer/ icinga-core: Remove icingia-core, missing prior review
[~andy/sunrise] / net-analyzer / icinga / icinga-1.0.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils
8
9 DESCRIPTION="A monitoring system based on Nagios"
10 HOMEPAGE="http://www.icinga.org/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="dbi ssl"
17
18 RDEPEND="dbi? ( dev-db/libdbi-drivers )
19         ssl? ( dev-libs/openssl )"
20 DEPEND="${RDEPEND}"
21
22 pkg_setup() {
23         enewgroup icinga
24         enewuser icinga -1 -1 -1 icinga
25 }
26
27 src_configure() {
28         econf --with-posix-regex \
29                 $(use_enable ssl) \
30                 $(use_enable dbi idoutils)
31 }
32
33 src_compile() {
34         emake all || die "emake failed"
35 }
36
37 src_install() {
38         emake DESTDIR="${D}" install-unstripped install-api install-init install-config install-commandmode || die
39         if use dbi; then
40                 emake DESTDIR="${D}" install-idoutils || die
41         fi
42         dodoc README THANKS AUTHORS || die "dodoc failed"
43 }