]> Pileus Git - ~andy/sunrise/blob - net-analyzer/hostmap/hostmap-0.2.2.ebuild
net-analyzer/hostmap: Fixed dependency issue in hostmap. Thanks for the catch sezdzimir
[~andy/sunrise] / net-analyzer / hostmap / hostmap-0.2.2.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 USE_RUBY="ruby18"
7
8 RUBY_FAKEGEM_EXTRAINSTALL="hostmap.conf discovery dictionaries extra"
9 RUBY_FAKEGEM_BINWRAP="hostmap"
10 RUBY_FAKEGEM_DOCDIR="doc"
11 RUBY_FAKEGEM_EXTRADOC="doc/Changelog.txt doc/README.pdf doc/THANKS.txt"
12
13 inherit ruby-fakegem
14
15 DESCRIPTION="Automatic hostname and virtual hosts discovery tool written in Ruby"
16 HOMEPAGE="http://hostmap.lonerunners.net/"
17 SRC_URI="http://update.lonerunners.net/software/download/${P}.tgz"
18
19 LICENSE="GPL-3"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE=""
23
24 ruby_add_rdepend "dev-ruby/net-dns
25         dev-ruby/PlugMan"
26
27 all_ruby_prepare() {
28         mkdir bin || die
29         mv hostmap.rb bin/hostmap || die
30 }