]> Pileus Git - ~andy/sunrise/blob - media-video/swfmill/swfmill-0.3.2.ebuild
dev-db/cppdb: Adding ~amd64 keyword
[~andy/sunrise] / media-video / swfmill / swfmill-0.3.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="xml2swf and swf2xml processor with import functionalities"
8 HOMEPAGE="http://swfmill.org"
9 SRC_URI="http://swfmill.org/releases/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 # until media-video/mtasc is fixed
17 RESTRICT="test"
18
19 RDEPEND="dev-libs/libxml2
20         dev-libs/libxslt
21         media-libs/freetype:2
22         media-libs/libpng:0
23         sys-libs/zlib"
24
25 DEPEND="${RDEPEND}
26         sys-devel/libtool
27         virtual/pkgconfig"
28
29 # until parallel compilation is fixed upstream
30 # https://github.com/djcsdy/swfmill/issues/21
31 src_compile() {
32         emake -j1
33 }