]> Pileus Git - ~andy/sunrise/blob - media-video/sn9c1xx/sn9c1xx-1.48.ebuild
net-misc/wolman: Properly fix qt deps
[~andy/sunrise] / media-video / sn9c1xx / sn9c1xx-1.48.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils linux-info
6
7 DESCRIPTION="A driver for sn9c1xx (webcam) devices, like the Sweex Mini cam"
8 HOMEPAGE="http://www.linux-projects.org/modules/mydownloads/viewcat.php?op=&cid=2"
9 SRC_URI="http://dev.gentooexperimental.org/~dreeevil/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 CONFIG_CHECK="VIDEO_DEV USB"
20
21 src_unpack() {
22         unpack ${A}
23         cd "${S}"
24         epatch "${FILESDIR}"/${P}-kbuild.patch
25         set_arch_to_kernel
26 }
27
28 src_compile() {
29         emake clean || die "emake clean failed"
30         emake modules || die "emake modules failed"
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install || die "emake install failed"
35         dodoc ChangeLog sn9c102.txt || die "installing docs faild"
36 }