]> Pileus Git - ~andy/sunrise/blob - media-video/periscope/periscope-0.2.4.ebuild
8c3c9d8ef7391fe434d0e6c725898ce96bfc34a4
[~andy/sunrise] / media-video / periscope / periscope-0.2.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.6"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.[45] 3.*"
9
10 inherit distutils
11
12 DESCRIPTION="Python module for searching subtitles on the web"
13 HOMEPAGE="http://code.google.com/p/periscope/"
14 SRC_URI="http://periscope.googlecode.com/files/python-${PN}_${PV}.orig.tar.gz"
15
16 LICENSE="LGPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="nautilus"
20
21 RDEPEND="dev-python/beautifulsoup
22         nautilus? ( dev-python/nautilus-python
23         dev-python/notify-python )"
24 DEPEND="${RDEPEND}
25         dev-python/setuptools"
26
27 pkg_postinst() {
28         elog "If you want to use Periscope as a Nautilus plugin, follow the instructions"
29         elog "on this url: http://code.google.com/p/periscope/wiki/NautilusSupport"
30 }