]> Pileus Git - ~andy/sunrise/blob - media-video/palantir-client/palantir-client-2.6.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-video / palantir-client / palantir-client-2.6.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit eutils qt3
7
8 MY_PN=${PN/-client/}
9 MY_P=${MY_PN}-${PV}
10
11 DESCRIPTION="Transmit live video, audio and data over a TCP/IP network, as well as to control remote devices."
12 HOMEPAGE="http://www.fastpath.it/products/palantir/index.php"
13 SRC_URI="http://www.fastpath.it/products/${MY_PN}/pub/${MY_P}.tgz"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~x86"
18 IUSE=""
19
20 DEPEND=">=x11-libs/qt-3.3:3"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${MY_P}/clients/qt
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28
29         # patching in subdir because there are ebuilds for parts of this package
30         epatch "${FILESDIR}/${PV}-senselessConfigFileHandling.patch"
31
32         sed -i  \
33                 -e 's/-ggdb//' \
34                 -e 's/CPPFLAGS/CPPFLAGS+/' \
35                 -e 's/g++/$(CXX)/g' \
36                 Makefile || die "sed failed"
37
38         # Fix the relative path
39         for file in $(ls *.cpp *.h); do
40                 sed -i \
41                         -e 's#./icons#/usr/share/palantir-client/icons#g' \
42                         -e 's#./pclient.ini#/usr/share/palantir-client/pclient.ini#g' \
43                         ${file} || die "sed failed"
44         done
45 }
46
47 src_install() {
48         dobin pclient
49         dodoc README
50         insinto /usr/share/${PN}
51         doins -r icons/
52         doins pclient.ini
53 }