]> Pileus Git - ~andy/sunrise/blob - media-video/palantir-client/palantir-client-2.6.ebuild
0e7c00e408b9213ebf074cbb1e034b4eed6a21c3
[~andy/sunrise] / media-video / palantir-client / palantir-client-2.6.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils qt3
6
7 MY_PN=${PN/-client/}
8 MY_P=${MY_PN}-${PV}
9
10 DESCRIPTION="Palantir is a Linux-based streaming system designed to transmit live video, audio and data over a TCP/IP network, as well as to control remote devices."
11 HOMEPAGE="http://www.fastpath.it/products/palantir/index.php"
12 SRC_URI="http://www.fastpath.it/products/${MY_PN}/pub/${MY_P}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE=""
18
19 DEPEND="$(qt_min_version 3.3)"
20 RDEPEND="${DEPEND}"
21
22 S=${WORKDIR}/${MY_P}/clients/qt
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27
28         # patching in subdir because there are ebuilds for parts of this package
29         epatch "${FILESDIR}/${PV}-senselessConfigFileHandling.patch"
30
31         sed -i  \
32                 -e 's/-ggdb//' \
33                 -e 's/CPPFLAGS/CPPFLAGS+/' \
34                 -e 's/g++/$(CXX)/g' \
35                 Makefile || die "sed failed"
36
37         # Fix the relative path
38         for file in $(ls *.cpp *.h); do
39                 sed -i \
40                         -e 's#./icons#/usr/share/palantir-client/icons#g' \
41                         -e 's#./pclient.ini#/usr/share/palantir-client/pclient.ini#g' \
42                         ${file} || die "sed failed"
43         done
44 }
45
46 src_install() {
47         dobin pclient
48         dodoc README
49         insinto /usr/share/${PN}
50         doins -r icons/
51         doins pclient.ini
52 }