]> Pileus Git - ~andy/sunrise/blob - media-video/palantir/palantir-2.6.ebuild
media-video/palantir: New ebuilds for bug 126282
[~andy/sunrise] / media-video / palantir / palantir-2.6.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Palantir is a Linux-based streaming system designed to transmit live video, audio and data over a TCP/IP network, as well as to control remote devices."
8 HOMEPAGE="http://www.fastpath.it/products/palantir/index.php"
9 SRC_URI="http://www.fastpath.it/products/${PN}/pub/${P}.tgz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 DEPEND="media-libs/jpeg"
17 RDEPEND="${DEPEND}"
18
19 S="${S}/server"
20
21 PALANTIR_USER="palantir"
22 PALANTIR_PIPE_PATH="/var/run/palantir/telmu_pipe"
23
24 src_unpack() {
25         unpack ${A}
26         epatch "${FILESDIR}/${PV}-makefile.patch"
27         sed -i -e "s#/usr/local/share/palantir/telmu_pipe#${PALANTIR_PIPE_PATH}#" "${S}/tools/set_sensor"
28 }
29
30 pkg_setup() {
31         enewuser ${PALANTIR_USER}
32 }
33
34 src_compile() {
35         export NAMED_PIPE="${PALANTIR_PIPE_PATH}"
36         emake || die "emake failed"
37 }
38
39 src_install() {
40         dobin palantir
41         newbin tools/sysfeed palantir_sysfeed
42         newbin tools/set_sensor palantir_set_sensor
43
44         insinto /usr/share/${PN}
45         doins -r pict
46         
47         insinto /etc/palantir
48         doins "${FILESDIR}/palantir.conf.sample"
49
50         dodir /var/log
51         touch "${D}/var/log/palantir.log"
52
53         dodir /var/run/palantir
54         mkfifo "${D}${NAMED_PIPE}"
55         fperms 0600 "${NAMED_PIPE}"
56         fowners ${PALANTIR_USER} "${NAMED_PIPE}" /var/log/palantir.log
57
58         newinitd "${FILESDIR}/palantir.init" palantir
59
60         dodoc doc/* README TODO
61         doman man/palantir.1 man/palantir.conf.5
62         dohtml man/html/*
63 }