]> Pileus Git - ~andy/sunrise/blob - media-video/ov51x-jpeg/ov51x-jpeg-1.5.9-r1.ebuild
sci-visualization/tulip: Fix qt deps
[~andy/sunrise] / media-video / ov51x-jpeg / ov51x-jpeg-1.5.9-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit base linux-mod
6
7 DESCRIPTION="OV51x driver for Linux which supports JPEG decompression inside the kernel"
8 HOMEPAGE="http://www.rastageeks.org/ov51x-jpeg/index.php/Main_Page"
9 SRC_URI="http://www.rastageeks.org/downloads/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 CONFIG_CHECK="USB VIDEO_V4L1_COMPAT"
17 ERROR_USB="${P} requires Host-side USB support (CONFIG_USB)."
18 ERROR_VIDEO_V4L1_COMPAT="${P} require support for the Video For Linux API 1 compatibility layer (CONFIG_VIDEO_V4L1_COMPAT)."
19 MODULE_NAMES="ov51x-jpeg(media/video:)"
20 BUILD_TARGETS="all"
21 BUILD_PARAMS="KERNELDIR=${KV_DIR}"
22
23 PATCHES=(
24         "${FILESDIR}"/${PV}-kernel-messages.patch
25         "${FILESDIR}"/${PV}-2.6.29_final.patch
26         )
27
28 src_install() {
29         linux-mod_src_install
30         dodoc ChangeLog || die "dodoc failed"
31 }