]> Pileus Git - ~andy/sunrise/blob - media-video/ov51x-jpeg/ov51x-jpeg-1.0.0.ebuild
media-video/ov51x-jpeg: Removed redundant S=${WORKDIR}/${P}
[~andy/sunrise] / media-video / ov51x-jpeg / ov51x-jpeg-1.0.0.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-mod
6
7 DESCRIPTION="OV51x driver for Linux which supports JPEG decompression inside the kernel"
8 HOMEPAGE="http://www.rastageeks.org/ov51x-jpeg/index.php/Main_Page"
9 SRC_URI="http://www.rastageeks.org/downloads/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="sys-kernel/linux-headers"
17 RDEPEND=""
18
19 BUILD_TARGETS="all"
20 BUILD_PARAMS="KDIR=${KV_DIR}"
21 MODULE_NAMES="ov51x-jpeg(media/video:)"
22 CONFIG_CHECK="USB VIDEO_V4L1_COMPAT"
23 ERROR_USB="${P} requires Host-side USB support (CONFIG_USB)."
24 ERROR_VIDEO_V4L1_COMPAT="${P} require support for the Video For Linux API 1 compatibility layer (CONFIG_VIDEO_V4L1_COMPAT)."