]> Pileus Git - ~andy/sunrise/blob - media-video/huludesktop/huludesktop-0.9.3.ebuild
media-video/huludesktop: New Ebuild for bug 288372. Thanks chiiph and jlec.
[~andy/sunrise] / media-video / huludesktop / huludesktop-0.9.3.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils multilib rpm
8
9 DESCRIPTION="Hulu desktop"
10 HOMEPAGE="http://www.hulu.com/labs/hulu-desktop-linux"
11 SRC_URI="amd64? ( http://download.hulu.com/${PN}.x86_64.rpm -> ${P}.x86_64.rpm )
12                 x86? ( http://download.hulu.com/${PN}.i386.rpm -> ${P}.i386.rpm )"
13
14 LICENSE="Hulu-EULA"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND="www-plugins/adobe-flash
20                 x11-libs/gtk+:2
21                 dev-libs/glib"
22
23 src_install() {
24         insinto /etc/${PN}
25         doins etc/${PN}/hd_keymap.ini || die "Failed doins"
26
27         dobin usr/bin/${PN} || die "Failed dobin"
28
29         domenu usr/share/applications/${PN}.desktop || die "Failed domenu"
30         doicon usr/share/pixmaps/${PN}.png || die "Failed doicon"
31         dodoc usr/share/doc/${PN}/README || die "Failed dodoc"
32 }
33
34 pkg_postinst() {
35         einfo "This program can utilize a remote control.  Please install"
36         einfo "app-misc/lirc if you wish to use a remote with ${PN}."
37         einfo
38         ewarn "The file ~/.${PN} should be created for you if you start Hulu Desktop"
39         ewarn "but the path to the flash plugin is not set by default."
40         ewarn
41         ewarn "You need to add the following to ~/.${PN}:"
42         ewarn "[flash]"
43         ewarn "flash_location = /usr/$(get_libdir)/nsbrowser/plugins/libflashplayer.so"
44 }