]> Pileus Git - ~andy/sunrise/blob - media-video/ekd/ekd-2.0.0.20100315.ebuild
games-fps/unreal-tournament-operationnapali: Update HOMEPAGE and replace SRC_URI...
[~andy/sunrise] / media-video / ekd / ekd-2.0.0.20100315.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 PYTHON_DEPEND="2:2.5"
8 SUPPORT_PYTHON_ABIS="1"
9
10 inherit eutils python versionator
11
12 MY_PV=$(replace_version_separator 1 '_' $(replace_version_separator 2 '-' $(replace_version_separator 3 '_')))
13 MY_P=${PN}_linux_source_${MY_PV}
14
15 DESCRIPTION="Post-production video editing"
16 HOMEPAGE="http://ekd.tuxfamily.org/"
17 SRC_URI="http://download.tuxfamily.org/${PN}forum/${PN}/appli/linux/sources/${MY_P}.tar.gz"
18
19 LICENSE="GPL-3"
20 SLOT="0"
21 KEYWORDS="~amd64"
22 IUSE=""
23
24 RDEPEND="virtual/libintl
25         dev-python/imaging
26         dev-python/numpy
27         dev-python/PyQt4[X]
28         media-gfx/imagemagick
29         media-video/ffmpeg2theora
30         media-video/mjpegtools
31         media-video/mplayer
32         media-sound/lame
33         media-sound/sox"
34 RESTRICT_PYTHON_DEPEND="2.4 3*"
35
36 S=${WORKDIR}/${MY_P}
37
38 src_prepare() {
39         python_convert_shebangs 2 ekd_gui.py
40 }
41
42 src_install() {
43         insinto /usr/share/${PN}
44         doins -r * || die
45
46         building() {
47                 make_wrapper ekd-${PYTHON_ABI} "$(PYTHON) /usr/share/${PN}/ekd_gui.py"
48         }
49         python_execute_function building
50
51         python_generate_wrapper_scripts "${D}/usr/bin/ekd"
52
53         dodoc README_LISEZMOI.txt || die
54
55         doicon icone_${PN}.png || die
56         make_desktop_entry ${PN} EKD icone_${PN}
57 }