]> Pileus Git - ~andy/sunrise/blob - media-video/avi-ogminfo/avi-ogminfo-2.0.5.ebuild
dev-libs/libserial: Adding ~amd64 keyword
[~andy/sunrise] / media-video / avi-ogminfo / avi-ogminfo-2.0.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="4"
6
7 inherit autotools eutils
8
9 DESCRIPTION="A small program for getting information about media files"
10 HOMEPAGE="http://avi-ogminfo.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="nls"
17
18 DEPEND="
19         dev-libs/libxml2
20         x11-libs/gtk+:2
21         dev-cpp/gtkmm:2.4
22         virtual/ffmpeg
23         media-libs/libogg
24         media-libs/libvorbis"
25 RDEPEND=${DEPEND}
26
27 src_prepare() {
28         epatch "${FILESDIR}"/${P}-ffmpeg.patch
29         eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 $(use_enable nls) \
35                 --disable-rpath
36 }