]> Pileus Git - ~andy/sunrise/blob - media-video/aegisub/aegisub-2.1_pre1981.ebuild
Automatic update to categories
[~andy/sunrise] / media-video / aegisub / aegisub-2.1_pre1981.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 WX_GTK_VER="2.8"
7 inherit eutils wxwidgets
8
9 MY_PV="${PV/_pre/-dev-r}"
10 MY_P="${PN}-${MY_PV}"
11
12 DESCRIPTION="Advanced SSA/ASS subtitle editor"
13 HOMEPAGE="http://malakith.net/aegiwiki/Main_Page"
14 SRC_URI="http://www.mahou.org/~verm/aegisub/archives/${MY_P}.tar.gz"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="alsa debug +ffmpeg lua openal perl pulseaudio spell ruby"
20
21 RDEPEND="=x11-libs/wxGTK-2.8*[opengl]
22         media-libs/libass
23         media-libs/fontconfig
24         media-libs/freetype
25
26         alsa? ( media-libs/alsa-lib )
27         pulseaudio? ( media-sound/pulseaudio )
28         openal? ( media-libs/openal )
29
30         perl? ( dev-lang/perl )
31         ruby? ( dev-lang/ruby )
32         lua? ( dev-lang/lua )
33
34         spell? ( app-text/hunspell )
35         ffmpeg? ( media-video/ffmpeg )"
36
37 DEPEND="${RDEPEND}
38         dev-util/pkgconfig
39         media-gfx/imagemagick
40         dev-libs/glib"
41
42 S="${WORKDIR}/${MY_P}"
43
44 src_configure() {
45         econf --with-libass \
46         $(use_with alsa) \
47         --without-portaudio \
48         $(use_with pulseaudio) \
49         $(use_with openal) \
50         $(use_with lua) \
51         $(use_with ruby) \
52         $(use_with perl) \
53         $(use_with ffmpeg) \
54         $(use_with spell hunspell) \
55         $(use_enable debug)
56 }
57
58 src_install() {
59         emake DESTDIR="${D}" install || die "emake install failed"
60         doicon "${FILESDIR}"/${PN}.png
61         make_desktop_entry "${PN}" "Aegisub" "${PN}" "AudioVideo;Video;"
62 }