]> Pileus Git - ~andy/sunrise/blob - media-tv/zattoo-bin/zattoo-bin-2.2.8.5561.ebuild
media-tv/zatoo-bin: quotations
[~andy/sunrise] / media-tv / zattoo-bin / zattoo-bin-2.2.8.5561.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit rpm
6
7 MY_PV=${PV}-1
8 MY_P=${PN/-bin}-${MY_PV}
9
10 DESCRIPTION="live TV on your PC (Switzerland and Denmark only)"
11 HOMEPAGE="http://zattoo.com/"
12 SRC_URI="http://download.zattoo.com/${MY_P}.i386.rpm"
13
14 LICENSE="Zattoo"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE=""
18
19 #NOTE: As there is no real documentation, I don't know
20 #      exactly what dependancies are needed.
21 #      These are just the ones I came across:
22 DEPEND=""
23 RDEPEND=">=sys-libs/glibc-2.4
24         x11-libs/gtkglext
25         app-crypt/libgssapi
26         app-crypt/mit-krb5
27         gnome-base/libgnome
28         gnome-base/libgnomeui
29         media-libs/alsa-lib
30         dev-libs/openssl"
31
32 RESTRICT="strip"
33 QA_TEXTRELS="usr/lib/zattoo/*"
34
35 S=${WORKDIR}
36
37 src_install() {
38         dobin usr/bin/zattoo_player usr/bin/zattood
39         insinto /usr/lib/zattoo
40         doins usr/lib/zattoo/*
41         insinto /usr/share/zattoo_player
42         doins -r usr/share/zattoo_player/*
43         insinto /usr/share/applications
44         doins usr/share/applications/zattoo_player.desktop
45         doenvd "${FILESDIR}"/77zattoo-bin
46 }