]> Pileus Git - ~andy/sunrise/blob - media-tv/otrdecoder-bin/otrdecoder-bin-518.ebuild
Remove <herd>no-herd</herd>.
[~andy/sunrise] / media-tv / otrdecoder-bin / otrdecoder-bin-518.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Decoder for onlinetvrecorder.com (German)"
6 HOMEPAGE="http://www.onlinetvrecorder.com/"
7 SRC_URI="http://www.onlinetvrecorder.com/downloads/${PN}-linux-static-v${PV}.tar.bz2"
8 LICENSE="as-is"
9
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12
13 IUSE="X"
14
15 RDEPEND="X? ( gnome-base/libglade
16                 dev-python/pygtk )"
17 DEPEND=""
18
19 RESTRICT="strip"
20 S="${WORKDIR}/otrdecoder-bin-linux-static-v${PV}"
21
22 src_install() {
23         dobin otrdecoder
24         if use X; then
25                 insinto /usr/share/${P}
26                 doins decoder.glade
27
28                 sed -i -e "s:xml = gtk.glade.XML(join(decoderpath,'decoder.glade')):xml = gtk.glade.XML(join('/usr/share/${P}/','decoder.glade')):" \
29                         otrdecoder-gui
30                 dobin otrdecoder-gui
31         fi
32
33         dodoc README.OTR
34 }