]> Pileus Git - ~andy/sunrise/blob - media-tv/freetuxtv/freetuxtv-0.5.2.ebuild
media-tv/freetuxtv: Drop unneeded sys-apps/hal dependency leftover from old version.
[~andy/sunrise] / media-tv / freetuxtv / freetuxtv-0.5.2.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="WebTV player for french people to watch ADSL TV"
8 HOMEPAGE="http://code.google.com/p/freetuxtv/"
9 SRC_URI="http://freetuxtv.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="nls"
15
16 RDEPEND="x11-libs/gtk+:2
17         dev-libs/glib:2
18         dev-libs/dbus-glib
19         dev-db/sqlite:3
20         media-video/vlc[live,rtsp]
21         net-misc/curl
22         x11-libs/libnotify
23         nls? ( virtual/libintl )"
24 DEPEND="${RDEPEND}
25         nls? ( sys-devel/gettext )"
26
27 src_configure() {
28         econf $(use_enable nls)
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die
33         dodoc AUTHORS ChangeLog NEWS README || die
34 }