]> Pileus Git - ~andy/sunrise/blob - media-tv/freetuxtv/freetuxtv-0.5.1.ebuild
ff1f72aa4d36871c537435feb2551537d11c9bd0
[~andy/sunrise] / media-tv / freetuxtv / freetuxtv-0.5.1.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="WebTV player for french people to watch ADSL TV"
8 HOMEPAGE="http://code.google.com/p/freetuxtv/"
9 SRC_URI="http://freetuxtv.googlecode.com/files/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="nls"
15
16 RDEPEND="x11-libs/gtk+:2
17         dev-libs/glib:2
18         dev-libs/dbus-glib
19         sys-apps/hal
20         dev-db/sqlite:3
21         media-video/vlc[live,rtsp]
22         net-misc/curl
23         x11-libs/libnotify
24         nls? ( virtual/libintl )"
25 DEPEND="${RDEPEND}
26         nls? ( sys-devel/gettext )"
27
28 src_configure() {
29         econf $(use_enable nls)
30 }
31
32 src_install(){
33         emake DESTDIR="${D}" install || die
34         dodoc AUTHORS ChangeLog NEWS README || die
35 }