]> Pileus Git - ~andy/sunrise/blob - media-tv/em28xx-new/em28xx-new-0.0.20090319.129883114507514.ebuild
media-radio/rivendell: whitespace, readability
[~andy/sunrise] / media-tv / em28xx-new / em28xx-new-0.0.20090319.129883114507514.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-info linux-mod mercurial versionator
6
7 printf -v EHG_REVISION '%012x' "$(get_version_component_range 4)"
8 EHG_REPO_URI="http://mcentral.de/hg/~mrec/em28xx-new/"
9
10 DESCRIPTION="next generation em28xx driver including dvb support"
11 HOMEPAGE="http://mcentral.de/"
12 SRC_URI=""
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 S=${WORKDIR}/${PN}
19
20 CONFIG_CHECK="VIDEO_V4L2 DVB_CORE"
21
22 pkg_setup() {
23         linux-mod_pkg_setup
24         if kernel_is lt 2 6 21; then
25                 eerror "You need at least kernel 2.6.21"
26                 die "Kernel too old"
27         fi
28
29         if linux_chkconfig_present VIDEO_EM28XX; then
30                 ewarn "In-kernel em28xx drivers enabled, disable or remove them from"
31                 ewarn "/lib/modules/${KV_FULL} if you experience problems."
32         fi
33 }
34
35 src_compile() {
36         set_arch_to_kernel
37         emake || die "Compiling kernel modules failed"
38 }
39
40 src_install() {
41         insinto /lib/modules/${KV_FULL}/empia
42         local extglob_bak=$(shopt -p extglob)
43         shopt -s extglob # portage disables bash extglob in ebuilds
44         doins $(echo {!(precompiled)/,}*.ko)
45         eval ${extglob_bak} # restore previous extglob status
46 }