]> Pileus Git - ~andy/sunrise/blob - media-tv/democracy/democracy-0.9.0_rc2.ebuild
media-tv/democracy: version bump
[~andy/sunrise] / media-tv / democracy / democracy-0.9.0_rc2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils eutils versionator
6
7 #MY_P="Democracy-${PV}"
8 MY_P="Democracy-$(replace_version_separator "_" "-")"
9 DESCRIPTION="Democracy is a free and open internet TV platform."
10 HOMEPAGE="http://www.getdemocracy.com"
11 SRC_URI="http://participatoryculture.org/nightlies/${MY_P}.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86 ~amd64 ~ppc"
15 RDEPEND="dev-python/pyrex
16                 >virtual/python-2.4
17                 media-libs/xine-lib
18                 dev-libs/boost
19                 >=dev-python/pygtk-2.0
20                 dev-python/gnome-python-extras
21                 www-client/mozilla-firefox
22                 x11-libs/libX11"
23 DEPEND="${RDEPEND}
24                 dev-util/pkgconfig"
25
26 DOCS="README"
27
28 S=${WORKDIR}/${MY_P}/platform/gtk-x11
29
30 pkg_setup() {
31         if ! built_with_use python berkdb; then
32                 eerror "You must build python with berkdb support"
33                 die "Please re-emerge python with berkdb USE flag ON"
34         fi
35
36         if ! grep -q compiler.find /usr/lib/python2.4/distutils/unixccompiler.py; then
37                 eerror "You need to apply a patch to make distutils use the correct RPATH."
38                 eerror "To do this execute the following command:"
39                 eerror "wget -q 'http://sourceforge.net/tracker/download.php?group_id=5470&atid=305470&file_id=144928&aid=1254718' -O -|patch -p1 -d /usr/lib/python2.4"
40                 die "python version not patched"
41         fi
42 }
43
44 src_unpack() {
45         unpack ${A}
46         cd "${S}"
47         epatch "${FILESDIR}"/democracy-as-needed-libX11.patch
48 }
49
50 pkg_postinst(){
51         if ! built_with_use xine-lib aac ffmpeg mad asf flac sdl win32codecs; then
52                 ewarn "The Democracy team recommends you to emerge xine-lib as follows:"
53                 ewarn ""
54                 ewarn "# echo \"media-libs/xine-lib aac ffmpeg mad asf flac sdl win32codecs\" \ "
55                 ewarn ">> /etc/portage/package.use && emerge xine-lib"
56                 ewarn ""
57                 ewarn "This way you will have support enabled for the most popular"
58                 ewarn "video and audio formats. You may also want to add support"
59                 ewarn "for theora and vorbis"
60         fi
61 }