]> Pileus Git - ~andy/sunrise/blob - media-tv/democracy/democracy-0.8.4.ebuild
x11-plugins/deskbar-handlers-converter: New ebuild for bug 147423
[~andy/sunrise] / media-tv / democracy / democracy-0.8.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 MY_P="Democracy-${PV}"
8 DESCRIPTION="Democracy is a free and open internet TV platform."
9 HOMEPAGE="http://www.getdemocracy.com"
10 SRC_URI="ftp://ftp.osuosl.org/pub/pculture.org/democracy/src/${MY_P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 #currently the support for firefox appears to be broken
15 #IUSE="gecko-sdk mozilla firefox"
16
17 RDEPEND="dev-python/pyrex
18                 >virtual/python-2.4
19                 media-libs/xine-lib
20                 dev-libs/boost
21                 >=dev-python/pygtk-2.0
22                 dev-python/gnome-python-extras
23                 www-client/mozilla
24                 net-libs/gecko-sdk"
25                 #this are pull by gnome-python
26                 #gnome-base/gconf
27                 #gnome-base/gnome-vfs
28
29 #TODO  gnome2_src_configure ${G2CONF}
30 # maybe add support in this way
31 #/usr/portage/dev-python/gnome-python-extras/gnome-python-extras-2.14.0.ebuild 
32
33
34 DEPEND="${RDEPEND}
35                 dev-util/pkgconfig"
36
37 DOCS="CREDITS README LAYOUT license.txt"
38
39 S="${WORKDIR}/${MY_P}/platform/gtk-x11/"
40
41 src_unpack() {
42         unpack ${A}
43         cd ${S}
44         epatch ${FILESDIR}/setup.py-gecko-sdk-${PV}.patch
45 }
46
47 pkg_postinst(){
48 if ! built_with_use xine-lib aac ffmpeg mad \
49 asf flac sdl win32codecs ; then
50
51 ewarn "The Democracy team recommends you to emerge xine-lib as follows:"
52 ewarn ""
53 ewarn " echo \"media-libs/xine-lib aac ffmpeg mad asf flac sdl win32codecs\" >>
54 /etc/portage/package.use && emerge xine-lib"
55 ewarn ""
56 ewarn "This way you will have support enable for the most popular video and
57 audio formats"
58 ewarn "You may also want to add support for theora and vorbis "
59 fi
60 }