]> Pileus Git - ~andy/sunrise/blob - media-tv/democracy/democracy-0.8.4.1.ebuild
media-tv/democracy - New democracy ebuild thanks to Louis C. in bug 131527
[~andy/sunrise] / media-tv / democracy / democracy-0.8.4.1.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils eutils
6
7 MY_P="Democracy-${PV}"
8 DESCRIPTION="Democracy is a free and open internet TV platform."
9 HOMEPAGE="http://www.getdemocracy.com"
10 SRC_URI="ftp://ftp.osuosl.org/pub/pculture.org/democracy/src/${MY_P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64" 
14 #currently the support for firefox appears to be broken
15 #IUSE="gecko-sdk mozilla firefox"
16
17 RDEPEND="dev-python/pyrex
18                 >virtual/python-2.4
19                 media-libs/xine-lib
20                 dev-libs/boost
21                 >=dev-python/pygtk-2.0
22                 dev-python/gnome-python-extras
23                 net-libs/gecko-sdk
24                 || ( x11-libs/libX11 virtual/x11 )"
25                 #www-client/mozilla, maybe even www-client/mozilla-firefox?
26                 #this are pull by gnome-python
27                 #gnome-base/gconf
28                 #gnome-base/gnome-vfs
29
30 #TODO  gnome2_src_configure ${G2CONF}
31 # maybe add support in this way
32 #/usr/portage/dev-python/gnome-python-extras/gnome-python-extras-2.14.0.ebuild 
33
34
35 DEPEND="${RDEPEND}
36                 dev-util/pkgconfig"
37
38 DOCS="README"
39
40 S="${WORKDIR}/${MY_P}/platform/gtk-x11/"
41
42 src_unpack() {
43         unpack ${A}
44         cd ${S}
45         epatch ${FILESDIR}/democracy-{use-gecko-sdk,as-needed-libX11}.patch
46 }
47
48 pkg_postinst(){
49         if ! built_with_use -a xine-lib aac ffmpeg mad asf flac sdl win32codecs; then 
50                 ewarn "The Democracy team recommends you to emerge xine-lib as follows:"
51                 ewarn ""
52                 ewarn "# echo \"media-libs/xine-lib aac ffmpeg mad asf flac sdl win32codecs\" \ "
53                 ewarn ">> /etc/portage/package.use && emerge xine-lib"
54                 ewarn ""
55                 ewarn "This way you will have support enabled for the most popular"
56                 ewarn "video and audio formats. You may also want to add support"
57                 ewarn "for theora and vorbis"
58         fi
59 }