]> Pileus Git - ~andy/sunrise/blob - media-tv/ati-genericv4l/ati-genericv4l-2.6.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-tv / ati-genericv4l / ati-genericv4l-2.6.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-mod
6
7 MY_P="${PN/ati-/}-${PV}"
8 S=${WORKDIR}
9
10 DESCRIPTION="Generic V4L2 driver for ATI Mach64-based tv cards (All-in-Wonder, etc)"
11 HOMEPAGE="http://www.rulerofearth.com/"
12 SRC_URI="http://www.rulerofearth.com/${MY_P}.tbz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17
18 IUSE=""
19 DEPEND=""
20 RDEPEND=""
21
22 CONFIG_CHECK="VIDEO_DEV VIDEO_V4L1_COMPAT VIDEO_V4L2"
23 ERROR_VIDEO_DEV="${P} requires Video For Linux support (CONFIG_VIDEO_DEV)."
24 ERROR_VIDEO_V4L1_COMPAT="${P} requires Video For Linux API 1 compatible Layer (CONFIG_VIDEO_V4L1_COMPAT)."
25 ERROR_VIDEO_V4L2="${P} requires Video For Linux API 2 support (CONFIG_VIDEO_V4L2)."
26 BUILD_TARGETS="default"
27
28 pkg_setup() {
29         linux-mod_pkg_setup
30
31         MODULE_NAMES="genericv4l(v4l:${S}/v4l2)"
32         BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
33 }
34
35 src_compile() {
36         # assists in debugging
37         # emake KERNELPATH=${KV_OUT_DIR} info || die "emake info failed"
38
39         linux-mod_src_compile
40 }
41
42 src_install() {
43         linux-mod_src_install
44
45         dodoc v4l2/README_ENG.TXT v4l2/README_FR.TXT
46 }
47
48 pkg_postinst() {
49         # what's the purpose of this???
50         # einfo "Removing old modules (just in case)"
51         # local moddir="${ROOT}/lib/modules/${KV_FULL}/v4l/"
52         # [[ -f "${moddir}/genericv4l.${KV_OBJ}" ]] && rm "${moddir}/genericv4l.${KV_OBJ}"
53
54         linux-mod_pkg_postinst
55
56         elog
57         elog "NOTE: if you load the module and Tuner is not found"
58         elog "(look in dmesg) you can try to specify the tuner with the tunertype parameter"
59         elog "If you have a SECAM tuner you MUST specify tunertype=2"
60         elog
61         ewarn "If you are using GATOS as well, keep in mind that you cannot use"
62         ewarn "both at the same time (you CANNOT watch tv in overlay mode and use"
63         ewarn "my driver to capture video at the same time)"
64 }