]> Pileus Git - ~andy/sunrise/blob - media-sound/soma/soma-2.4.ebuild
media-sound/soma: Remove unneccessay die, moved to EAPI=4
[~andy/sunrise] / media-sound / soma / soma-2.4.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils
8
9 DESCRIPTION="Audio and video broadcast manager"
10 HOMEPAGE="http://www.somasuite.org/"
11 SRC_URI="http://www.somasuite.org/src/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="ffmpeg"
17
18 DEPEND="
19         dev-libs/openssl
20         >=sys-libs/ncurses-5.0
21         >=sys-libs/readline-5.0
22         dev-libs/libxml2
23         ffmpeg? ( media-video/ffmpeg )"
24 RDEPEND=${DEPEND}
25
26 src_prepare() {
27         epatch "${FILESDIR}"/${P}-pid.patch
28 }
29
30 src_configure() {
31         econf \
32                 $(use_enable ffmpeg)
33 }
34
35 pkg_postinst() {
36         einfo " *** *** ***"
37         einfo "If you can afford to donate us some money let us know, we also need"
38         einfo "new and old working hardware."
39         einfo " "
40         einfo "you can send a mail to"
41         einfo " "
42         einfo " mail: soma@inventati.org"
43         einfo "  or: bakunin@autistici.org"
44         einfo " *** *** ***"
45 }