]> Pileus Git - ~andy/sunrise/blob - media-sound/ripoff/ripoff-0.8.3.ebuild
app-text/orayta: Bump, bump EAPI, fix qt deps
[~andy/sunrise] / media-sound / ripoff / ripoff-0.8.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="Simple GTK+ Based CD Ripper"
8 HOMEPAGE="http://ripoffc.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}c/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="flac mp3 vorbis"
15
16 RDEPEND="
17         dev-libs/libcdio
18         media-libs/libcddb
19         x11-libs/gtk+:2
20         flac? ( media-libs/flac )
21         mp3? ( media-sound/lame )
22         vorbis? ( media-libs/libvorbis )"
23 DEPEND="${RDEPEND}"
24
25 src_configure() {
26         econf \
27                 $(use_enable flac) \
28                 $(use_enable mp3) \
29                 $(use_enable vorbis)
30 }