]> Pileus Git - ~andy/sunrise/blob - media-sound/pithos/pithos-9999.ebuild
app-misc/japanese-vocabulary: Adding ~amd64 keyword, fixing qt deps properly
[~andy/sunrise] / media-sound / pithos / pithos-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.6"
7 SUPPORT_PYTHON_ABIS="1"
8 inherit bzr distutils
9
10 EBZR_REPO_URI="lp:${PN}"
11 DESCRIPTION="A Pandora Radio (pandora.com) player for the GNOME Desktop"
12 HOMEPAGE="http://kevinmehall.net/p/pithos/"
13
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS=""
17 IUSE="gnome"
18
19 DEPEND="dev-python/python-distutils-extra"
20
21 RDEPEND="dev-python/pyxdg
22         dev-python/pygobject:2
23         dev-python/notify-python
24         dev-python/pygtk
25         dev-python/gst-python
26         dev-python/dbus-python
27         media-libs/gst-plugins-good
28         media-libs/gst-plugins-bad
29         media-plugins/gst-plugins-faad
30         media-plugins/gst-plugins-soup
31         gnome? ( gnome-base/gnome-settings-daemon )
32         !gnome? ( dev-libs/keybinder[python] )"
33
34 RESTRICT_PYTHON_ABIS="2.[45] 3.*"
35 DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
36
37 src_prepare() {
38         distutils_src_prepare
39
40         # bug #216009
41         # avoid writing to /root/.gstreamer-0.10/registry.xml
42         export GST_REGISTRY="${T}"/registry.xml
43 }
44
45 src_install() {
46         distutils_src_install --prefix="${EPREFIX}/usr"
47 }