]> Pileus Git - ~andy/sunrise/blob - media-sound/peapod/peapod-0.140.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / media-sound / peapod / peapod-0.140.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils
6
7 DESCRIPTION="A command line podcast receiver that supports downloads via HTTP and BitTorrent"
8 HOMEPAGE="http://www.peapodpy.org/"
9 SRC_URI="http://peapodpy.org/downloads/${P}.tar.gz"
10 KEYWORDS="~amd64 ~x86"
11 LICENSE="GPL-2"
12 SLOT="0"
13 IUSE="id3 bittorrent vorbis"
14
15 DEPEND="dev-python/pyxml
16         >=dev-python/urlgrabber-2.9.6
17         bittorrent? ( >=net-p2p/bittorrent-4.0.0 )
18         id3? ( dev-python/eyeD3 )
19         vorbis? ( media-sound/vorbis-tools )"
20
21 RDEPEND=${DEPEND}
22
23 DOCS="README docs/about.txt docs/configuration.txt docs/dependencies.txt docs/getting.txt docs/using.txt"
24
25 pkg_postinst() {
26         elog "Start by running peapod"
27         elog "Then edit the file in .peapod/peapod.xml with the feeds"
28         elog "For reference look at /usr/share/doc/${PF}/configuration.txt.gz"
29 }
30
31 src_install() {
32         distutils_src_install
33         use bittorrent || rm -f "${D}/usr/bin/btclient.py"
34 }