]> Pileus Git - ~andy/sunrise/blob - media-sound/oss2jack/oss2jack-0.25.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update header
[~andy/sunrise] / media-sound / oss2jack / oss2jack-0.25.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Tool to create virtual dsp to connect OSS-based apps to jack"
6 HOMEPAGE="http://fort2.xdas.com/~kor/oss2jack/"
7 SRC_URI="http://fort2.xdas.com/~kor/oss2jack/${P}.tar.gz"
8
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="~x86"
12 IUSE=""
13
14 DEPEND="media-libs/libsamplerate
15         media-sound/fusd-kor
16         sys-apps/realtime-lsm"
17 RDEPEND=${DEPEND}
18
19 src_compile() {
20         econf --with-fusd=/usr || die "configure failed"
21         emake || die "emake failed"
22 }
23
24 src_install() {
25         dobin "${S}"/src/oss2jack/oss2jack
26         dodoc README
27 }
28
29 pkg_postinst() {
30         elog "To use oss2jack you need to first start jackd"
31         elog "and then run oss2jack to create the dsp device"
32 }