]> Pileus Git - ~andy/sunrise/blob - media-sound/om/om-0.2.0.ebuild
media-sound/somax: Drop media-sound/somax abandoned by upstream and unfindable distfi...
[~andy/sunrise] / media-sound / om / om-0.2.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Modular audio synthesizer using Jack, LADSPA, DSSI etc."
6 HOMEPAGE="http://www.nongnu.org/om-synth/"
7 SRC_URI="http://savannah.nongnu.org/download/om-synth/${P}.tar.gz"
8
9 IUSE="alsa debug dssi gtk ladspa lash patch-loader"
10 LICENSE="GPL-2"
11 KEYWORDS="~x86"
12 SLOT="0"
13
14 RDEPEND=">=media-libs/liblo-0.22
15         media-sound/jack-audio-connection-kit
16         alsa? ( >=media-libs/alsa-lib-1.0 )
17         dssi? ( media-libs/dssi )
18         ladspa? ( media-libs/ladspa-sdk )
19         lash? ( >=media-sound/lash-0.5.0 )
20         patch-loader? ( dev-libs/libxml2 )
21         gtk? ( >=dev-cpp/gtkmm-2.4
22                 >=dev-cpp/libgnomecanvasmm-2.6
23                 >=dev-cpp/libglademm-2.4.1 )"
24
25 DEPEND="${RDEPEND}
26         dev-util/pkgconfig"
27
28 pkg_setup() {
29         if use gtk && ! use patch-loader ; then
30                 eerror 'USE="gtk" requires USE="patch-loader" too.'
31                 die "gtk without patch-loader detected"
32         fi
33 }
34
35 src_compile() {
36
37         econf \
38                 $(use_enable alsa) \
39                 $(use_enable debug) \
40                 $(use_enable dssi) \
41                 $(use_enable ladspa) \
42                 $(use_enable lash) \
43                 $(use_enable patch-loader) \
44                 $(use_enable gtk gtk-client) \
45                 || die "econf failed"
46
47         emake || die "emake failed"
48 }
49
50 src_install() {
51         emake DESTDIR="${D}" install || die "emake install failed"
52         dodoc AUTHORS ChangeLog NEWS README THANKS TODO
53 }
54
55 pkg_postinst() {
56         einfo
57         elog "NOTE: If you want to be able to run the om-synth example"
58         elog "patches (in /usr/share/om/patches/), please install the"
59         elog "media-plugins/omins (>=0.2.0) package, too."
60         einfo
61 }