]> Pileus Git - ~andy/sunrise/blob - media-sound/nero-aac-encoder-bin/nero-aac-encoder-bin-1.5.1.ebuild
dev-python/hyphenator: New ebuild for dev-python/hyphenator (bug #300382).
[~andy/sunrise] / media-sound / nero-aac-encoder-bin / nero-aac-encoder-bin-1.5.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="Nero free (as in beer) AAC encoder"
8 HOMEPAGE="http://www.nero.com/eng/technologies-aac-codec.html"
9 SRC_URI="NeroAACCodec-${PV}.zip"
10
11 LICENSE="Nero-AAC-encoder"
12 SLOT="0"
13 KEYWORDS="-* ~amd64 ~x86"
14 IUSE=""
15
16 DEPEND="app-arch/unzip"
17 # We need a proper way to specify dependency on multlib profile on amd64
18 RDEPEND="amd64? ( sys-devel/gcc[multilib]
19         sys-libs/glibc[multilib] )"
20
21 RESTRICT="fetch"
22
23 pkg_nofetch() {
24         einfo "You need to download the file ${SRC_URI} from"
25         einfo "http://www.nero.com/eng/downloads-nerodigital-nero-aac-codec.php"
26         einfo "and put it to /usr/portage/distfiles manually"
27         einfo "due to license restrictions."
28 }
29
30 src_install() {
31         dobin linux/* || die
32         dodoc readme.txt changelog.txt || die
33 }