]> Pileus Git - ~andy/sunrise/blob - media-sound/mtag/mtag-9999.ebuild
drop KEYWORDS
[~andy/sunrise] / media-sound / mtag / mtag-9999.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils subversion
6
7 DESCRIPTION="the fast media tag lib"
8 HOMEPAGE="http://mtag.berlios.de/"
9 SRC_URI=""
10 ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/mtag/trunk/mtag"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="doc"
16
17 RDEPEND="media-libs/taglib
18         >=dev-db/sqlite-3.3.12"
19 DEPEND="dev-util/cmake
20         doc? ( app-doc/doxygen )
21         ${RDEPEND}"
22
23 src_compile() {
24         cmake "${S}" || die "compile failed!"
25         emake  || die "compile failed!"
26         if use doc; then
27                 doxygen "${S}" || die "compile failed!"
28         fi
29 }
30
31 src_install() {
32         dobin mtag
33         dodoc README ChangeLog AUTHORS
34         if use doc; then
35                 dohtml html/*
36         fi
37 }