]> Pileus Git - ~andy/sunrise/blob - media-sound/mtag/mtag-9999.ebuild
net-misc/fatrat: Properly fix qt deps
[~andy/sunrise] / media-sound / mtag / mtag-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit cmake-utils subversion
6
7 DESCRIPTION="Fast media tag lib"
8 HOMEPAGE="http://mtag.berlios.de/"
9 SRC_URI=""
10 ESVN_REPO_URI="http://svn.berlios.de/svnroot/repos/mtag/trunk/mtag"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="doc"
16
17 RDEPEND="media-libs/taglib
18         >=dev-db/sqlite-3.3.12"
19 DEPEND="doc? ( app-doc/doxygen )
20         ${RDEPEND}"
21
22 CMAKE_IN_SOURCE_BUILD=1
23
24 src_compile() {
25         cmake-utils_src_compile
26         if use doc; then
27                 doxygen "${S}" || die "compile failed!"
28         fi
29 }
30
31 src_install() {
32         dobin ${PN} || die "dobin failed"
33         dodoc AUTHORS ChangeLog README || die "dodoc failed"
34         if use doc; then
35                 dohtml -r html/* || die "dohtml failed"
36         fi
37 }