]> Pileus Git - ~andy/sunrise/blob - media-sound/mtag/mtag-3.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / media-sound / mtag / mtag-3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit cmake-utils eutils
8
9 DESCRIPTION="Fast media tag lib"
10 HOMEPAGE="http://mtag.berlios.de/"
11 SRC_URI="mirror://berlios/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 RDEPEND="media-libs/taglib
19         dev-db/sqlite:3"
20 DEPEND="${RDEPEND}"
21
22 CMAKE_IN_SOURCE_BUILD=1
23
24 src_prepare() {
25         epatch "${FILESDIR}"/${P}-gcc46.patch
26 }
27
28 src_install() {
29         dobin ${PN}
30         dodoc AUTHORS ChangeLog README
31         if use doc; then
32                 dohtml -r html/*
33         fi
34 }