]> Pileus Git - ~andy/sunrise/blob - media-sound/madfuload/madfuload-1.2.ebuild
sci-geosciences/aweather: Bump to 0.8, update homepage, and test on amd64
[~andy/sunrise] / media-sound / madfuload / madfuload-1.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit eutils linux-info
7
8 DESCRIPTION="M-Audio DFU firmware loader for MobilePre, Ozone, Sonica and Transit USB audio interfaces"
9 HOMEPAGE="http://usb-midi-fw.sourceforge.net/"
10 SRC_URI="mirror://sourceforge/usb-midi-fw/${P}.tar.gz"
11
12 LICENSE="GPL-2 madfuload"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 pkg_setup() {
18         kernel_is le 2 6 8 && die "Kernel > 2.6.8 needed"
19         linux-info_pkg_setup
20 }
21
22 src_prepare() {
23         epatch "${FILESDIR}/${P}"-*.patch
24 }
25
26 src_install() {
27         emake DESTDIR="${D}" install || die "install failed"
28         dodoc README || die "adding documentation failed"
29 }
30
31 pkg_postinst() {
32         einfo "You need to reload udev rules before connecting the device:"
33         einfo "# udevadm control --reload-rules"
34         einfo "Also you might have to change the MobilePre RUN parameter"
35         einfo "in /etc/udev/rules.d/42-madfuload.rules to"
36         einfo "\"/usr/sbin/madfuload -l -D %E{DEVICE} -3 -f /usr/share/usb/maudio/ma004103.bin\""
37 }